Msys can't find glib

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Msys can't find glib

Prabhulinga Swamy B S
Hi,
    I'm trying to build gstreamer-0.10.28 using Msys. As a dependency, I
successfully compiled glib-2.21.3

    While configuring glib, i've used,
       $ ./configure --prefix=/mingw

       Now when I tried to configure gstreamer with the same prefix,
checking for GLIB is failing. I've added paths to glib directory in Msys
environment( paths added link this: My
computer->properties->advanced->environment variables). Still facing the
same problem. I think I'm doing mistake in setting paths.

environment variables in MSYS:

LIB=C:\Program Files\Microsoft Visual Studio 8\VC\ATLMFC\LIB;C:\Program
Files\Microsoft Visual Studio 8\VC\LIB;C:\Program Files\Microsoft Visual
Studio 8\VC\PlatformSDK\lib;C:\Program Files\Microsoft Visual Studio
8\SDK\v2.0\lib;C:\msys\mingw\lib;C:\msys\lib

INCLUDE=C:\Program Files\Microsoft Visual Studio
8\VC\ATLMFC\INCLUDE;C:\Program Files\Microsoft Visual Studio
8\VC\INCLUDE;C:\Program Files\Microsoft Visual Studio
8\VC\PlatformSDK\include;C:\Program Files\Microsoft Visual Studio
8\SDK\v2.0\include;C:\msys\mingw\include;C:\msys\mingw\glib-2.0\include;C:\msys\include


Please help.

Thanks for your attention.

--

Regards,
Prabhu





------------------------------------------------------------------------------
ThinkGeek and WIRED's GeekDad team up for the Ultimate
GeekDad Father's Day Giveaway. ONE MASSIVE PRIZE to the
lucky parental unit.  See the prize list and enter to win:
http://p.sf.net/sfu/thinkgeek-promo
_______________________________________________
Mingw-msys mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mingw-msys
Reply | Threaded
Open this post in threaded view
|

Re: Msys can't find glib

JonY-6
On 6/9/2010 16:08, Prabhulinga Swamy B S wrote:

> Hi,
>      I'm trying to build gstreamer-0.10.28 using Msys. As a dependency, I
> successfully compiled glib-2.21.3
>
>      While configuring glib, i've used,
>         $ ./configure --prefix=/mingw
>
>         Now when I tried to configure gstreamer with the same prefix,
> checking for GLIB is failing. I've added paths to glib directory in Msys
> environment( paths added link this: My
> computer->properties->advanced->environment variables). Still facing the
> same problem. I think I'm doing mistake in setting paths.
>
> environment variables in MSYS:
>
> LIB=C:\Program Files\Microsoft Visual Studio 8\VC\ATLMFC\LIB;C:\Program
> Files\Microsoft Visual Studio 8\VC\LIB;C:\Program Files\Microsoft Visual
> Studio 8\VC\PlatformSDK\lib;C:\Program Files\Microsoft Visual Studio
> 8\SDK\v2.0\lib;C:\msys\mingw\lib;C:\msys\lib
>
> INCLUDE=C:\Program Files\Microsoft Visual Studio
> 8\VC\ATLMFC\INCLUDE;C:\Program Files\Microsoft Visual Studio
> 8\VC\INCLUDE;C:\Program Files\Microsoft Visual Studio
> 8\VC\PlatformSDK\include;C:\Program Files\Microsoft Visual Studio
> 8\SDK\v2.0\include;C:\msys\mingw\include;C:\msys\mingw\glib-2.0\include;C:\msys\include
>
>
> Please help.
>
> Thanks for your attention.
>

Hi,

you can look at config.log found in the directory you ran gstreamer
configure. It should tell you the reason for failure.

------------------------------------------------------------------------------
ThinkGeek and WIRED's GeekDad team up for the Ultimate
GeekDad Father's Day Giveaway. ONE MASSIVE PRIZE to the
lucky parental unit.  See the prize list and enter to win:
http://p.sf.net/sfu/thinkgeek-promo
_______________________________________________
Mingw-msys mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mingw-msys
Reply | Threaded
Open this post in threaded view
|

Re: Msys can't find glib

Prabhulinga Swamy B S
JonY wrote:
On 6/9/2010 16:08, Prabhulinga Swamy B S wrote:
  
Hi,
     I'm trying to build gstreamer-0.10.28 using Msys. As a dependency, I
successfully compiled glib-2.21.3

     While configuring glib, i've used,
        $ ./configure --prefix=/mingw

        Now when I tried to configure gstreamer with the same prefix,
checking for GLIB is failing. I've added paths to glib directory in Msys
environment( paths added link this: My
computer->properties->advanced->environment variables). Still facing the
same problem. I think I'm doing mistake in setting paths.

environment variables in MSYS:

LIB=C:\Program Files\Microsoft Visual Studio 8\VC\ATLMFC\LIB;C:\Program
Files\Microsoft Visual Studio 8\VC\LIB;C:\Program Files\Microsoft Visual
Studio 8\VC\PlatformSDK\lib;C:\Program Files\Microsoft Visual Studio
8\SDK\v2.0\lib;C:\msys\mingw\lib;C:\msys\lib

INCLUDE=C:\Program Files\Microsoft Visual Studio
8\VC\ATLMFC\INCLUDE;C:\Program Files\Microsoft Visual Studio
8\VC\INCLUDE;C:\Program Files\Microsoft Visual Studio
8\VC\PlatformSDK\include;C:\Program Files\Microsoft Visual Studio
8\SDK\v2.0\include;C:\msys\mingw\include;C:\msys\mingw\glib-2.0\include;C:\msys\include


Please help.

Thanks for your attention.

    

Hi,

you can look at config.log found in the directory you ran gstreamer 
configure. It should tell you the reason for failure.

------------------------------------------------------------------------------
ThinkGeek and WIRED's GeekDad team up for the Ultimate 
GeekDad Father's Day Giveaway. ONE MASSIVE PRIZE to the 
lucky parental unit.  See the prize list and enter to win: 
http://p.sf.net/sfu/thinkgeek-promo
_______________________________________________
Mingw-msys mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mingw-msys


  
Hi JonY,
    Thank you for your help.

    I looked ad config.log file and found that environment variable PKG_CONFIG_PATH  was  missing in MSYS environment.
    So I just added env variable which is set to glib-2.0.pc (package config file) link this.

    PKG_CONFIG_PATH=/mingw/lib/pkgconfig

    gstreamer configured successfully.

    Now problem while doing 'make' with gstreamer. Showing as,

Making all in pkgconfig
Making all in gst
Making all in parse

./grammar.y: conflicts: 37 shift/reduce, 5 reduce/reduce
/bin/m4: unrecognized option `--gnu'
Try `/bin/m4 --help' for more information.
make[4]: *** [grammar.tab.h] Error 141
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

I'm looking for it, can't figure out the problem yet.
I'll appreciate any help.
-- 

Regards,
Prabhu


------------------------------------------------------------------------------
ThinkGeek and WIRED's GeekDad team up for the Ultimate
GeekDad Father's Day Giveaway. ONE MASSIVE PRIZE to the
lucky parental unit.  See the prize list and enter to win:
http://p.sf.net/sfu/thinkgeek-promo
_______________________________________________
Mingw-msys mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mingw-msys